SmartWB Display zeigt Müll

Fragen und Antworten zur Software hinter EVSE-WiFi
pete
Beiträge: 19
Registriert: Mo 24. Mai 2021, 23:52

SmartWB Display zeigt Müll

Beitrag von pete »

Guten Abend!

ich betreibe seit 2 Jahren eine SmartWB, Softwarestand 2.4.2
Sie läuft im Normalmodus, wobei der zulässige Ladestrom je nach PV Überschuss alle 30s per API (OpenHab) angepasst wird. Das funktioniert schon recht lange ohne Probleme, Fahrzeug ist ein Skoda Enyaq (VW MEB).


Was mich allerdings nervt:
Das Display zeigt nach einer Weile nur noch Datenmüll an, siehe Anhang. Dieser Anzeigemüll verändert / wandert alle paar Sekunden, mal sieht man wieder kurz irgendwas sinnvolles, dann wieder nur Testbild-Rauschen.
Nach einem Reboot ist für einige Stunden wieder alles gut und dann geht das von vorne los. Momentan behelfe ich mir damit, dass die Box nachts per API resetted wird. Spätestens mittags sieht es aber wieder so aus.

Wo liegt das Problem und wie löse ich das?
Dateianhänge
PXL_20230508_093746643.jpg
PXL_20230508_093746643.jpg (35.52 KiB) 2434 mal betrachtet
PXL_20230508_093741524.jpg
PXL_20230508_093741524.jpg (37.94 KiB) 2434 mal betrachtet

ppistole
Beiträge: 34
Registriert: Sa 4. Sep 2021, 12:35

Re: SmartWB Display zeigt Müll

Beitrag von ppistole »

Ich sehe das selbe Problem.
Firmware 2.4.1

aiole
Beiträge: 1150
Registriert: Di 12. Mai 2020, 10:54

Re: SmartWB Display zeigt Müll

Beitrag von aiole »

Das "Wandern" ist gewollt, um die oLED-Belastung zu senken. D.h. die Anzeige wird aller paar Sekunden um ein paar Pixel versetzt. Der "Datenmüll" ist allerdings neu und habe ich noch nie gesehen. Wir könnten zunächst das Display wechseln, um der Ursache näher zu kommen.
Bitte an den Support wenden.

ps
Hast du mal die Displayanzeigezeit heruntergestellt? Wenn nicht - bitte probieren. Es geht zunächst nur um die Ursachenidentifikation.

Mainzelmann
Beiträge: 8
Registriert: Sa 18. Dez 2021, 22:49

Re: SmartWB Display zeigt Müll

Beitrag von Mainzelmann »

Kann ich ebenfalls bestätigen. Bei mir im Display tauch einfach ein leeres Viereck auf, oberhalb ist alles deutlich erkennbar und unterhalb ist nur Schnee...

Tauch auch nach diversen Resets immer wieder auf

Bild
Dateianhänge
PXL_20230605_174257436_copy_1388x1849_1.jpg
PXL_20230605_174257436_copy_1388x1849_1.jpg (323.6 KiB) 2384 mal betrachtet

pete
Beiträge: 19
Registriert: Mo 24. Mai 2021, 23:52

Re: SmartWB Display zeigt Müll

Beitrag von pete »

aiole hat geschrieben:
Fr 26. Mai 2023, 19:49
Das "Wandern" ist gewollt, um die oLED-Belastung zu senken. D.h. die Anzeige wird aller paar Sekunden um ein paar Pixel versetzt. Der "Datenmüll" ist allerdings neu und habe ich noch nie gesehen. Wir könnten zunächst das Display wechseln, um der Ursache näher zu kommen.
Bitte an den Support wenden.

ps
Hast du mal die Displayanzeigezeit heruntergestellt? Wenn nicht - bitte probieren. Es geht zunächst nur um die Ursachenidentifikation.

Das Displaytimeout habe ich gerade von 180s auf 30s runtergestellt. Werde morgen mal nachsehen, ob wieder "Datenmüll" angezeigt wird.

Da es ja doch mehrere User betrifft, macht ein Displaytausch vermutlich weniger Sinn, oder?

aiole
Beiträge: 1150
Registriert: Di 12. Mai 2020, 10:54

Re: SmartWB Display zeigt Müll

Beitrag von aiole »

Ihr seid die einzigen 3 bis dato.

Dank der Modularität lässt sich der Halter mit 2 Schrauben lösen und dann das Display mit 2 weiteren Schrauben (!Kunststoffabstandsscheiben enthalten!) rel. leicht wechseln.
Die gesamte Front kann dazu, wie in der Anleitung beschrieben, mit einem ausgeklappten Zollstock "fixiert" werden.

Die Frage ist, was die Ursache ist. Display selbst oder Ansteuerung?

pete
Beiträge: 19
Registriert: Mo 24. Mai 2021, 23:52

Re: SmartWB Display zeigt Müll

Beitrag von pete »

Seit Umstellung auf 30s Display Timeout ist das Problem nicht wieder aufgetreten. Mit den vorherigen Einstellungen hätte sich der Datenmüll schon längst wieder gezeigt.

Ich nehme jetzt mal den nächtlichen Reboot raus, und falls das Problem sich wieder zeigt, melde ich mich.

Erstmal besten Dank für die schnelle Hilfe!

aiole
Beiträge: 1150
Registriert: Di 12. Mai 2020, 10:54

Re: SmartWB Display zeigt Müll

Beitrag von aiole »

Danke fürs feedback. Berichte mit neuem Test bitte weiter.

pete
Beiträge: 19
Registriert: Mo 24. Mai 2021, 23:52

Re: SmartWB Display zeigt Müll

Beitrag von pete »

Leider zu früh gefreut. Es tritt ohne nächtlichen Reboot auch bei 30s Displaytimeout auf.
Der Support hat sich zwischenzeitlich gemeldet, dass ich ein neues Display bekommen soll. Melde mich, sobald es verbaut ist.


Heute morgen gegen 09:05

PXL_20230621_090557741.MP.jpg
PXL_20230621_090557741.MP.jpg (18.92 KiB) 2254 mal betrachtet
PXL_20230621_090608907.jpg
PXL_20230621_090608907.jpg (16.79 KiB) 2254 mal betrachtet
PXL_20230621_090613308.jpg
PXL_20230621_090613308.jpg (13.14 KiB) 2254 mal betrachtet
.
.
und heute morgen gegen 09:55
PXL_20230621_095215284.jpg
PXL_20230621_095215284.jpg (17.02 KiB) 2254 mal betrachtet
PXL_20230621_095253874.jpg
PXL_20230621_095253874.jpg (17.03 KiB) 2254 mal betrachtet

aiole
Beiträge: 1150
Registriert: Di 12. Mai 2020, 10:54

Re: SmartWB Display zeigt Müll

Beitrag von aiole »

Der Wechsel geht gut, wenn zuerst der GfK-Halter an den 2 Schrauben gelöst wird. Alles ist modular verschraubt. Bitte auf die Kunststoff-U-Scheiben zw. oLED und Halter aufpassen!

Antworten