EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Fragen und Antworten zur Software hinter EVSE-WiFi
Antworten
BigKid
Beiträge: 20
Registriert: Fr 9. Apr 2021, 22:40

EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von BigKid »

Hiho...

ich betreibe meine EVSE im Remote Modus (mit EVCC). Mir fällt nun auf, dass sie sporadisch nicht mehr im Netz und nicht mehr erreichbar ist. Ob sie in den Fallback Modus oder AP Modus gegangen ist habe ich bisher nicht untersucht weil ich meistens genau dann einfach nur eins Will: LADEN weil grad Sonne im Überschuss und mein Akku zu leer für die nächste geplante größere fahrt.

Folgende Begleitumstände:
- Das WLAN wird nachts abgeschaltet (per Zeitsteuerung im Router) -> das isses aber nicht weil die Evse nicht jeden Morgen weg ist sondern so sporadisch alle 3-4 Wochen etwa
- Fritzbox <- WLAN -> Fritzbox als Repeater <- WLAN -> EVSE Wifi
- Am Repeater hängt dann per Kabel auch mein Smartmeter und mein Wechselrichter und die haben keine Probleme.
- Ein Reset der Evse hilft immer (nicht Factory Reset, einfach nur Neustart)
- Version 2.2.4
- keine mir bekannten Stromausfälle...

aiole
Beiträge: 994
Registriert: Di 12. Mai 2020, 10:54

Re: EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von aiole »

aus der "Kalten":
* Ein klar definierter AP hilft - also kein Mesh. 2,4/5GHz-Mix ist nicht hilfreich. => Ein kleiner, stromsparender 2,4GHz-WLAN-AP tut es am besten.
* Ich habe hier mehrere smartWB über Monate 24/7 ohne Netzwerkausfallerscheinungen am Laufen. Das Nachtabschalten kann m.E. schon ein Problem darstellen. Ich würde es zumindest testweise über >2 Monate mit 24/7-Betrieb probieren. Zumindest spricht der erfolgreiche Neustart mit korrekter WLAN-Einwahl dafür.

BigKid
Beiträge: 20
Registriert: Fr 9. Apr 2021, 22:40

Re: EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von BigKid »

Das Wlan Nachts anzulassen kommt für mich nicht in Frage - ich hab auch mein Handy Nachts im Flugmodus…
Was ich mir vorstellen kann ist sobald für den zweiten Ladepunkt in Form einer OpenWB das Netz per Kabel in die Garage gelegt werden muss nen kleinen AP auf 2,4Ghz da hin zu machen und den mit minimaler Sendeleistung zu betreiben…
Aber trotzdem: Eigentlich erwarte ich von der smartWB dass sie sich nicht verbindungslos aufhängt sondern wieder reconnected sobald das Netz da ist…
Falls es überhaupt damit direkt zusammen hängt denn das Netz ist jede Nacht aus - die smartWB aber nicht jeden Tag weg…
Zuletzt geändert von BigKid am Mo 30. Aug 2021, 22:13, insgesamt 3-mal geändert.

aiole
Beiträge: 994
Registriert: Di 12. Mai 2020, 10:54

Re: EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von aiole »

Ich erwarte eher, dass wenn das WLAN längere Zeit aus ist, sie in den AP-Modus geht und ein eigenes WLAN-Netz aufspannt. Man muss immer den Zugriff sicherstellen. => Du bist dann nicht WLAN-frei.

Beim Re-Connect kann immer mal was schief gehen.
Schau das nächste Mal bitte, ob sie sich im AP-mode befindet (eigenes WLAN-Netz auf dem phone/tablet ersichtlich - meist "EVSE-Wifi" genannt).

Du könntest die smartWB ggf. gleich mit abschalten - sie ist "Kaltstop-fähig" :mrgreen: . Aber manchmal möchte man ja auch laden.
Die Idee mit dem Mini-AP + min. Sendeleistung ist gut. Ich empfehle den hier:
https://www.tp-link.com/de/home-network ... tl-mr3020/
Der hat als Einstellbarkeit für Transmit Power: high/middle/low , bietet nur 2,4GHz und ist sehr stromsparend.

BigKid
Beiträge: 20
Registriert: Fr 9. Apr 2021, 22:40

Re: EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von BigKid »

Dass die smartWB dann in den AP Modus geht ist mir recht wurscht von der Strahlung her… da sind dann ja ein paar Wände und ne Betondecke dazwischen - ich bild mir ja gar nicht ein dass man hier irgendwo noch ganz Strahlungsfrei sein kann…
Das Problem ist die Haupt Fritzbox neben meinem Schlafzimmer und wenn die aus ist dann ist die zweite im Repeater Modus im Schaltschrank halt mit aus (die ist da für den Wechselrichter und den Smartmeter ).
Aber das ist eh Temporär - mittelfristig bekommen wir Glasfaser und spätestens dann will ich das Netz per Ethernet in den Schaltschrank und in die Garage bringen… Und dann werden die Karten neu gemischt… Ein Netz mit geringster Sendeleistung auf 2,4 stört mich dann nicht und kann an bleiben…

Aber: Was ich nicht so gut finde ist dass sie nicht merkt wenn „ihr“ Nett wieder da ist… auch wenn was beim Connect schief geht sollte sie es ab und zu mal wieder versuchen…

aiole
Beiträge: 994
Registriert: Di 12. Mai 2020, 10:54

Re: EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von aiole »

@Mathias
Kannst Du bitte mal prüfen, ob so ein Automatikcheck schon integriert ist?
https://randomnerdtutorials.com/solved- ... 2-to-wifi/

Mathias
Administrator
Beiträge: 212
Registriert: Di 12. Mai 2020, 09:12

Re: EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von Mathias »

Ja, sowas ist natürlich integriert, sonst würde der Reconnect niemals funktionieren. Es wird bei "WLAN-Verlust" alle 30 Sekunden ein Reconnect versucht. Sowas ist natürlich aus der ferne immer schwer zu ermitteln. Ich bin gerade dabei, den Debug-Modus etwas zu optimieren, dass auch noch nach einem Reboot noch eine Auswertung möglich ist. Eventuell kommen wir damit weiter. Das wird mit der v2.2.5 dann kommen.

Gantenbein
Beiträge: 3
Registriert: Fr 29. Okt 2021, 08:27

Re: EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von Gantenbein »

Hallo,

ich Betreibe die EVSE-WIFI Wallbox mit der Software Version 2.2.4 und als remote Steuerung openWB auf einem Raspberry.
Das Wlan läuft bei mir 24/7. Immer nach ein paar Tagen kann ich die Wallbox nicht mehr erreichen im Netz über den Browser. Ich kann meinen Zoe noch laden aber Änderungen der Ladeleistung über openWB werden nicht mehr angenommen. Ich muß dann immer die Sicherung aus und wieder einschalten um mich wieder auf der Oberfläche anmelden zu können.
Wird es da eine Lösung geben?

Grüße Heiko

aiole
Beiträge: 994
Registriert: Di 12. Mai 2020, 10:54

Re: EVSE-WIFI verschwindet sporadisch aus WLAN (Remote Modus)

Beitrag von aiole »

Hallo Heiko,

das ist untypisch. Bitte prüfe, ob Du bei Verbindungsverlust:
* direkt auf das web-gui der smartWB kommst
* dort die obere Statusanzeige der Verbindung grün ist (bei Verlust rot ind nach 1 min Ladestop)
* ein Anpingen auf die smartWB-IP möglich ist (z.B. mit Netanalyzer-App (Android))

Eine IP-Fixierung per MAC vom DHCP-Server hast Du vorgenommen, um immer dieselbe IP für die smartWB zu haben?
VG

Antworten