Is my firmware correct?

Fragen und Antworten zur Hardware
Antworten
haajee
Beiträge: 2
Registriert: Di 25. Mai 2021, 23:33

Is my firmware correct?

Beitrag von haajee »

Hello,

I am new here to the forum. Today i recieved my EVSE DIN module. I am trying to connect it to a ESP32. But i can not get the RS485 activated. According to the documentation at boot the EVSE DIN should have a solid led for 2-3 seconds in which i have te press a button 5x which shorts AN to GND. But the LED is never solid. The LED starts flashing once every second right away.

Can anyone help me with my problem?

Many thanks in advance.

Haajee

aiole
Beiträge: 994
Registriert: Di 12. Mai 2020, 10:54

Re: Is my firmware correct?

Beitrag von aiole »

Guess your EVSE-DIN has Modbus deactivated. If 5x button procedure won't work, you must ask for the right firmware flash (! closed source !).
EVSE DIN bought at our shop should have Modbus activated.

haajee
Beiträge: 2
Registriert: Di 25. Mai 2021, 23:33

Re: Is my firmware correct?

Beitrag von haajee »

Hello AIOLE,

I bought the unit via the evse-wifi.de website (Bestellnummer #2047). So modbus is standard activated?

aiole
Beiträge: 994
Registriert: Di 12. Mai 2020, 10:54

Re: Is my firmware correct?

Beitrag von aiole »

Ok - we'll check this asap by #2047.
Do you use BASE-modul too?
https://www.evse-wifi.de/produkt/evse-wifi-2-0-base/

Mathias
Administrator
Beiträge: 212
Registriert: Di 12. Mai 2020, 09:12

Re: Is my firmware correct?

Beitrag von Mathias »

If the EVSE-LED starts to flash immediately at startup, Modbus is already activated. I checked your Order #2047: You received an EVSE DIN with already activated Modbus Interface.
Note: ESP32 does not support RS485 out of the box. You need a converter to communicate via RS485! We strongly recommend our base module, instead of an ESP32 Dev Module, as aiole already wrote. It has an integrated RS485 circuit for direct communication with EVSE DIN:
https://www.evse-wifi.de/produkt/evse-wifi-2-0-base/

Antworten