seltsames Verhalten bei Steuerung durch openWB

Allgemeine Themen rund um EVSE-WiFi
Antworten
kMgkgi
Beiträge: 34
Registriert: Fr 15. Okt 2021, 12:40

seltsames Verhalten bei Steuerung durch openWB

Beitrag von kMgkgi »

Hallo zusammen,

ich habe noch was.
Die smartWB ist als LP2 an der openWB angemeldet.
Wie man im Log der openWB sieht, stand der Lademodus erst auf "Sofort" als ich das Auto angesteckt habe.
Dann habe ich auf "Standby" umgestellt, weil eigentlich erst später geladen werden soll.

"Standby" ist auf Nachtladen (ab 20 Uhr) und Morgenladen (08-09 Uhr) eingestellt.
Nach meinem Verständnis hätte also gar nicht geladen werden dürfen.
Jetzt sieht man aber in beiden Logs, dass dies nicht der Fall ist. Mein gewünschter SoC ist zwischenzeitlich erreicht worden, so dass nun das Laden auch eingestellt ist.
Aber wieso hat die smartWB einfach geladen?
Und was sind die drei kurzen "Schluckauf" am Ende?

Die smartWB ist auf "remote" gestellt, meldet auch brav "Remote system connected". "Enable API" ist angehakt.
In der openWB ist die smartWB per SimpleEVSWifi angebunden.

Jemand eine Idee? Vielleicht auch dazu, wieso das Laden immer wieder mal kurz unterbrochen und dann fortgesetzt wurde?

Danke schon mal!


Log der smartWB

Code: Alles auswählen

Date	Duration	Energy	Price	Costs	StartReading	UID	Username
15.10.2021 13:34	00:12:10	1,18	26	0,3068	0	remote	remote
15.10.2021 13:47	00:01:32	0,09	26	0,0234	1,178	remote	remote
15.10.2021 13:51	00:11:10	1,32	26	0,3432	1,267	remote	remote
15.10.2021 14:20	00:13:31	1,59	26	0,4134	2,584	remote	remote
15.10.2021 14:34	00:06:06	0,62	26	0,1612	4,177	remote	remote
15.10.2021 14:55	00:00:43	0	26	0	4,8	remote	remote
15.10.2021 15:12	00:00:43	0	26	0	4,8	remote	remote
15.10.2021 15:15	00:00:44	0	26	0	4,8	remote	remote
15.10.2021 15:59	00:00:44	0	26	0	4,8	remote	remote
15.10.2021 16:06	00:00:44	0	26	0	4,8	remote	remote
15.10.2021 16:26	00:00:43	0	26	0	4,8	remote	remote

Ladelog openWB

Code: Alles auswählen

2021-10-15 14:41:01: LP2, Ladung gestoppt (LV0)
2021-10-15 14:21:02: LP2, Ladung gestartet (LV0)
2021-10-15 14:03:32: LP2, Ladung gestoppt (LV0)
2021-10-15 13:51:41: LP2, Ladung gestartet (LV0)
2021-10-15 13:48:52: LP2, Ladung gestoppt (LV0)
2021-10-15 13:47:41: LP2, Ladung gestartet (LV0)
2021-10-15 13:46:22: LP2, Ladung gestoppt (LV0)
2021-10-15 13:39:29: LP2, Lademodus Standby. Ladefreigabe noch aktiv. Stoppe Ladung (LV0)
2021-10-15 13:39:27: LP1, Lademodus Standby. Ladefreigabe noch aktiv. Stoppe Ladung (LV0)
2021-10-15 13:37:08: LP2, Lademodus Sofort. Ladung geändert auf 30 Ampere (LV0)
2021-10-15 13:36:56: LP2, Lademodus Sofort. Ladung geändert auf 31 Ampere (LV0)
2021-10-15 13:35:01: LP2, Ladung gestartet (LV0)
smartWB: 2.3.0-beta1
remote Steuerung per openWB (Nightly: 1.9.249)

aiole
Beiträge: 779
Registriert: Di 12. Mai 2020, 10:54

Re: seltsames Verhalten bei Steuerung durch openWB

Beitrag von aiole »

Es wurden erst vor ein paar Tagen Verbesserungen an der Interaktion oWB/sWB vorgenommen. Der "Schluckauf" wird z.B. jetzt aktiv von oWB unterbunden. Die Ursache gilt es aber individuell zu finden. Poste bitte noch Deine WLAN-Qualität xx dBm.

Des Weiteren nutze bitte:
* oWB als aktuelle nightly
* EWifi 2.2.4

kMgkgi
Beiträge: 34
Registriert: Fr 15. Okt 2021, 12:40

Re: seltsames Verhalten bei Steuerung durch openWB

Beitrag von kMgkgi »

Die Updates habe ich gemacht.
Mal schauen, ob es dadurch besser wird.

Das WLAN hat eine Qualität von -68. Also eigentlich ganz ok.
Die openWB ist per Powerline verbunden.
smartWB: 2.3.0-beta1
remote Steuerung per openWB (Nightly: 1.9.249)

kMgkgi
Beiträge: 34
Registriert: Fr 15. Okt 2021, 12:40

Re: seltsames Verhalten bei Steuerung durch openWB

Beitrag von kMgkgi »

So, also Nightly von gestern ist auf der openWB. Die smartWB auf 2.2.4

openWB ist weiterhin auf Standby. Nachtladen startet ab 20 Uhr. Insofern dürfte aktuell nicht geladen werden.
Dies scheint zu funktionieren, allerdings ist der Schluckauf noch immer da

Log openWB:

Code: Alles auswählen

2021-10-16 18:22:32: LP2, Ladung gestoppt (LV0)
2021-10-16 18:21:28: Alle Ladepunkte, Lademodus Stop. Stoppe Ladung (LV0)
2021-10-16 18:21:18: Alle Ladepunkte, Lademodus Stop. Stoppe Ladung (LV0)
2021-10-16 18:21:12: LP2, Ladung gestartet (LV0)
2021-10-16 18:21:08: Alle Ladepunkte, Lademodus Stop. Stoppe Ladung (LV0)
2021-10-16 18:06:21: LP2, Ladung gestoppt (LV0)
2021-10-16 18:05:18: Alle Ladepunkte, Lademodus Stop. Stoppe Ladung (LV0)
2021-10-16 18:05:02: LP2, Ladung gestartet (LV0)
Log smartWB:

Code: Alles auswählen

16.10.2021 18:20:47	0:29	0.05 kWh	0.01 €	remote	remote
16.10.2021 18:04:48	0:30	0.05 kWh	0.01 €	remote	remote
Update: der Eintrag von 18:21/18:22 ist auch der letzte. Seitdem bis jetzt kein erneuter Schluckauf.
Ich beobachte morgen nochmal
smartWB: 2.3.0-beta1
remote Steuerung per openWB (Nightly: 1.9.249)

kMgkgi
Beiträge: 34
Registriert: Fr 15. Okt 2021, 12:40

Re: seltsames Verhalten bei Steuerung durch openWB

Beitrag von kMgkgi »

Code: Alles auswählen

17.10.2021 02:00:34	0:44		0.00 €	remote	remote
17.10.2021 00:31:58	0:43		0.00 €	remote	remote
17.10.2021 00:30:04	0:44		0.00 €	remote	remote
17.10.2021 00:29:00	0:43		0.00 €	remote	remote
17.10.2021 00:27:38	0:44		0.00 €	remote	remote
17.10.2021 00:05:57	0:43		0.00 €	remote	remote
16.10.2021 23:56:07	0:48		0.00 €	remote	remote
16.10.2021 23:06:07	0:43		0.00 €	remote	remote
16.10.2021 23:00:18	0:44		0.00 €	remote	remote
16.10.2021 22:36:30	0:43		0.00 €	remote	remote
16.10.2021 21:45:45	39:22	4.59 kWh	1.19 €	remote	remote
16.10.2021 21:19:06	26:31	3.15 kWh	0.82 €	remote	remote
16.10.2021 20:40:52	37:57	4.47 kWh	1.16 €	remote	remote
16.10.2021 18:20:47	0:29	0.05 kWh	0.01 €	remote	remote
16.10.2021 18:04:48	0:30	0.05 kWh	0.01 €	remote	remote
Hier nochmal ein Update.
Das um 20:40 statt direkt um 20:00 geladen wurde, passt an der Stelle, weil das Auto zwischen 19:40 und 20:40 nicht anwesend war.

Hab jetzt mal den Timeout in openWB für den LP 2 um eine Sekunde erhöht. Vielleicht hilft das gegen den Schluckauf.
Wieso kommt es überhaupt zu dem Schluckauf? Vermutung meinerseits: kurzzeitiges WLAN-Problem. Aber wieso macht die smartWB dann überhaupt was?
smartWB: 2.3.0-beta1
remote Steuerung per openWB (Nightly: 1.9.249)

aiole
Beiträge: 779
Registriert: Di 12. Mai 2020, 10:54

Re: seltsames Verhalten bei Steuerung durch openWB

Beitrag von aiole »

Ja, hier hilft aktuell nur probieren.
In der neuen v2.3.0 kommt eine optional aktivierbare Syslog-Ausgabe, wo noch ein paar Zusatzinfos abgreifbar werden.

Ich habe das Problem übrigens noch nie gehabt (45...60dBm).

Antworten